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ЛАБОРАТОРНАЯ РАБОТА №1. СОЗДАНИЕ РАСТРОВЫХ 
ИЗОБРАЖЕНИЙ СРЕДСТВАМИ PHOTOSHOP

Цель работы: освоить начальные приемы обработки растро-
вой графики, применяя программу Photoshop.

1. РАСТРОВЫЕ ГРАФИЧЕСКИЕ РЕДАКТОРЫ

1.1. Работа с растровой графикой 

Растровая графика представляет изображения в виде масси-
ва цифр. Поэтому при большом увеличении все точечные изо-
бражения выглядят как мозаика или сетка, состоящая из мель-
чайших ячеек. Такая сетка имеет название растровой карты
(bitmap), ее единичный элемент называется пикселом (рис.1). 

Рис. 1. Пример простого пиксельного изображения 

В связи со способом отображения информации растровое 
изображение часто сравнивают с мозаичным панно. Действи-
тельно, если рассматривать мозаичное изображение вблизи (при 
сильном увеличении), то стыки между отдельными деталями хо-
рошо видны; если отойти подальше (что равносильно уменьше-
нию масштаба), то мелкие элементы сливаются, и мы видим кар-
тину слитно в целостном восприятии. Так же и с растровой гра-
фикой: если пикселы достаточно малы, то границы между ними 
незаметны и глаз воспринимает "пиксельную мозаику" как одно
целое изображение. 

При масштабировании растровых изображений возникают 
характерные искажения - "ступеньки" (aliasing или jaggies) 
(рис. 2). В большинстве растровых редакторов "ступеньки" уда-
ется частично убрать за счет специальных приемов (например, 
anti-aliasing), но качество картинки при этом заметно снижается. 
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1.1.1. Инструментальные средства растровых редакторов

К фундаментальным инструментам растровой графики от-
носятся такие инструменты обработки изображений, как: 

 инструменты выделения; 
 каналы и маски; 
 инструменты ретуширования; 
 гистограммы; 
 кривые; 
 инструменты для цветовой (цветовой баланс) и тоновой 

коррекции (уровни); 
 фильтры (спецэффекты); 
 слои. 

Рис. 2. Ухудшение качества при масштабировании изображения 

Кроме перечисленных инструментальных средств в состав 
растровых редакторов входит большое количество инструментов, 
названия которых ассоциируются с применением их в традици-
онной живописи и других приложениях: Аэрограф, Кисть, Ка-
рандаш, Ластик, Текст, Перо, Линия, Заливка, Пипетка, Транс-
формация, Масштаб, Рука, Рамка и т.п. Аналоги этих инструмен-
тов также имеются в большинстве векторных редакторов. 

1.2. Инструменты выделения. Маски 

Растровое изображение в отличие от векторного не содер-
жит объектов, которые можно легко "расцепить" для выполнения 
их индивидуального редактирования. Поэтому для создания, на-
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пример, коллажей (фотомонтажей) из отдельных фрагментов не-
скольких изображений каждый из них предварительно необходи-
мо выделить. Данный процесс напоминает процедуру вырезание 
отдельных фрагментов из целостного изображения и называется 
процессом выделения (или обтравки) изображений. 

Выделение (Selection) - это область, ограниченная замкнутой 
рамкой выделения в виде движущейся пунктирной линии (конту-
ра), которая отмечает часть изображения, доступную для копиро-
вания, редактирования и выполнения различных типов преобра-
зований. 

Маски - это один из базовых инструментов профессиональ-
ных растровых редакторов. 

Концепции маски и выделения тесно связаны, но несмотря 
на это понятие маски шире. Всякая маска включает в себя два ти-
па областей: непрозрачные и прозрачные. Первые используются 
для защиты закрываемых ими частей изображений или объектов 
от нежелательных изменений. Они, собственно, и выполняют 
функцию маскирования. Прозрачные области можно рассматри-
вать как отверстия в маске. Их используют для выделения фраг-
ментов изображения или объекта, которые собираются модифи-
цировать. Эти области называются выделенной областью, или 
выделением (обтравкой). 

Таким образом, маска не представляет собой нечто проти-
воположное выделению. Противоположными свойствами обла-
дают части маски, а именно защищенные и выбранные (выделен-
ные) области. Соотношение между этими частями не является 
постоянным. В процессе работы над изображением оно может 
изменяться за счет увеличения доли одной из них и соответст-
венно уменьшения доли другой. Для этой цели в растровых ре-
дакторах имеется специальный набор инструментов выделения. 

1.2.1. Маска и понятие альфа-канала

Количество цветовых каналов определяется количеством 
базовых цветов в используемой цветовой модели. Так, изображе-
ние в формате Grayscale имеет один канал, в цветовых моделях 
RGB и L*a*b - три канала, а в модели CMYK - четыре канала. В 
растровых редакторах цветовые каналы генерируются автомати-
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чески при создании или открытии изображения. В Photoshop дос-
туп к ним реализуется с помощью палитры Каналы (рис. 3), для 
отображения которой необходимо выбрать команду 
Window?ShowChannels (Окно?Показать каналы). Подобные сред-
ства, но под иными названиями используются и в других растро-
вых редакторах. 

Наряду с цветовыми каналами, число которых жестко опре-
делено типом используемой цветовой модели, в растровых редак-
торах возможно использование дополнительных каналов (альфа-
каналов), количество которых ограничено только возможностями 
компьютера. Данная разновидность каналов широко использует-
ся для ретуширования, компоновки и локальной коррекции изо-
бражений. 

Рис. 3. Палитра Каналы

Назначение альфа-каналов тесно связано с понятием маски. 
Более того, фактически каждый такой канал представляет собой 
маску. Поэтому создание маски приводит к одновременному соз-
данию альфа-канала, в который помещается "серое" изображение 
маски. 

Чтобы более четко раскрыть связь этих двух понятий, стоит 
остановиться на физической природе маски. Внешне маска напо-
минает трафарет. Говоря техническим языком, маска сама явля-
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ется изображением. Это изображение создается в модели 
Grayscale (Градации серого) и помещается поверх другого изо-
бражения, над фрагментами которого нужно выполнить опреде-
ленные операции. Для любого пиксела маски значение оттенка 
серого цвета можно изменять в пределах 256 градаций серого (от 
0 до 255). Область маски со значением цвета пикселов, равного 0 
(черный), полностью защищает изображение от изменений. Об-
ласть, пикселы которой имеют значение 255 (белый), полностью 
открыта для проведения изменений. Как уже отмечалось, такая 
область называется выбранной (выделенной). 

Как и цветовые, альфа-каналы хранятся в палитре Каналы. 
На приведенном выше рис. 3 отображены три монохромных цве-
товых канала: красный, зеленый и синий, и один альфа-канал, ис-
пользуемый для хранения соответствующей ему маски. Для рабо-
ты с альфа-каналами предусмотрен ряд инструментов, доступ к 
которым осуществляется с помощью набора кнопок, размещен-
ных в нижней части палитры Каналы. Краткий комментарий к 
назначению данных кнопок представлен в таблице 1.

Таблица 1

Кнопка
N Наименование Назначение

1 Загрузить канал 
как выделение Создает слой - маску

2 Сохранить выделе-
ние как канал

Созданная с помощью инструментов выде-
ления маска является временным объектом, 
который пропадает после закрытия изобра-
жения. Нажатие данной кнопки позволяет 
сохранить маску в виде канала для после-
дующей работы с ней

3 Создать новый ка-
нал

Создает новый канал, в момент открытия 
представляющий собой сплошную маску, в 
которой с помощью инструментов выделе-
ния создается область выделения

4 Удалить текущий 
канал

Удаляет активный в данный момент альфа-
канал
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1.2.2. Инструменты и методы ретуширования 

Традиционно применение инструментов ретуширования 
изображений заключается в ретуши фотографий и восстановле-
нии поврежденных изображений. Ретушь - коррекция изображе-
ния с целью устранения мелких дефектов, исправления тонально-
го и цветового балансов. 

Наиболее часто используемыми средствами ретуширования 
являются: инструменты клонирования, инструменты размытия, 
инструменты Палец и Губка, инструменты Осветлитель иЗа-
темнитель. Ниже будут рассмотрены функции, которые они вы-
полняют. 

Для ретуширования изображений можно использовать неко-
торые из фильтров, несмотря на то, что большинство из них 
предназначено для применения к изображению специальных эф-
фектов. В большинстве случаев для получения нужного эффекта 
их следует применять в совокупности с масками и выделениями. 
При работе с изображениями чаще всего приходится сталкивать-
ся с дефектами локального характера, такими, как царапины, 
пятна и другие подобные искажения. В данном случае процесс 
ретуширования можно осуществить без применения выделений и 
масок, используя лишь инструментальные средства локального 
улучшения. 

Инструменты клонирования (CloningTools) предназначены 
для копирования деталей из одного места изображения (неповре-
жденного) в другое (поврежденное). 

Инструменты размытия (Blur) и повышения резкости 
(Sharpen) позволяют соответственно локально снижать или уси-
ливать контраст между пикселами изображения. 

Инструменты Палец (Smudge) и Губка (Sponge) сглажива-
ют различия между соседними оттенками в тех местах, где про-
ходит кисть. 

Инструменты Осветлитель (Dodge) и Затемнитель (Burn) 
делают объекты более светлыми или тусклыми. 
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1.3. Гистограмма. Оценка изображения 

Инструмент Гистограмма (Histogram) позволяет оценить 
разброс между минимальной и максимальной яркостью изобра-
жения (динамический диапазон). С его помощью становится воз-
можным получить наглядное представление о распределении 
всех тонов в изображении. Поэтому гистограмма является одним 
из основных средств, используемых для контроля за тональными 
и цветовыми настройками изображения. Гистограммой называ-
ется график, отображающий распределение пикселов изображе-
ния по яркости. При построении этого графика по оси X откла-
дываются значения яркостей в диапазоне от 0 (черный) до 255 
(белый), а по оси Y - количество пикселов, имеющих соответст-
вующее значение яркости. Анализ гистограммы позволяет по-
нять, какие тоновые области изображения нуждаются в коррек-
ции и в какой именно. Также с помощью гистограммы можно 
оценить тоновый диапазон изображения, то есть определить, ка-
кие тоновые области доминируют: тени (темные области), света 
(светлые области) или средние тона. 

Термины тени (shadows), средние тона (midtones) и света
(highlights) используются в графических редакторах для обозна-
чения соответственно темных, средних и светлых тонов изобра-
жения. 

1.3.1. Тоновая коррекция изображения 

Смысл тоновой коррекции заключается в придании изобра-
жению максимального динамического диапазона. Это напрямую 
связано с настройкой яркости изображения. 

Тон - уровень (градация, оттенок) серого цвета. Тоновое 
изображение имеет непрерывную шкалу градаций серого от бе-
лого до черного. Для одного канала число таких градаций равно 
256. 

Для оценки и коррекции яркости и контрастности изобра-
жения, то есть для его тоновой коррекции, в профессиональных 
растровых редакторах имеется широкий набор средств. К ним от-
носятся мощные универсальные инструменты Уровни (Levels) и 
Кривые (Curves), а также более простые, например Яр-
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кость/Контраст (Brightness/Contrast), предназначенные для устра-
нения наиболее грубых дефектов типа недостаточной яркости 
или повышенной контрастности. 

1.3.2. Цветовая коррекция и цветовой баланс 

Цветокоррекция - изменение цветовых параметров пикселов 
(яркости, контрастности, цветового тона, насыщенности) с целью 
достижения оптимальных результатов. Наиболее распространен-
ными средствами, которые используются для повышения качест-
ва цветных изображений, являются такие команды, как Баланс 
цветов (Colorbalance) и Оттенок/Насыщение (Hue/Saturation). 

Цветовой баланс - соотношение цветов в изображении. Ре-
гулировка цветового баланса позволяет усилить или ослабить 
один цвет за счет другого дополнительного (комплементарного 
ему). 

1.4. Фильтры (Plug-ins) и спецэффекты (Effects) 

В основном фильтры предназначены для создания специ-
альных эффектов, таких, как имитация мозаики или какого-либо 
живописного стиля. С помощью трехмерных спецэффектов 
двухмерные графические программы способны преобразовать 
плоское двухмерное изображение в объемное. 

Фильтры и спецэффекты представляют собой небольшие 
программы, выполняющие заранее установленную последова-
тельность команд. Они автоматически вычисляют значения и ха-
рактеристики каждого пиксела изображения и затем модифици-
руют их в соответствии с новыми значениями. 

1.5. Работа со слоями 

Слой (layer) - дополнительный уровень (холст) для рисова-
ния, метафора прозрачной кальки. Каждый слой повторяет все 
параметры основного изображения - размеры, разрешение, цве-
товую модель, число каналов. При увеличении количества слоев 
возрастает размер изображения. Слои можно менять местами, де-
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лать невидимыми, а также можно рисовать только на одном слое, 
не затрагивая другие. 

Естественно, что если закрасить какой-либо слой сплошным 
рисунком или плотным сплошным цветом, то на нижних слоях не 
будет видно того, что там нарисовано. Однако компьютерная жи-
вопись позволяет сделать слой полупрозрачным, что открывает 
новые возможности в редактировании изображений. 

2. ОПИСАНИЕ ГРАФИЧЕСКОГО РЕДАКТОРА ADOBE
PHOTOSHOP

Графический редактор AdobePhotoshop представляет собой 
профессиональную программу для редактирования компьютер-
ной живописи и фото, создания и обработки полиграфических 
иллюстраций. 

Редактор Photoshop использует четыре цветовые модели -
HSB, RGB, LAB и CMYK. 

2.1. Панель инструментов 

Панель инструментов (toolsbar) является основной рабочей 
панелью Photoshop. Расположенные в ней инструменты делятся 
на основные и альтернативные (скрытые). Основные инструмен-
ты (рис. 1) видны в главном окне программы. Альтернативные 
инструменты спрятаны за теми иконками, у которых в правом 
нижнем углу есть маленький треугольник. Для выбора альтерна-
тивного инструмента нужно установить курсор на значок основ-
ного инструмента, нажать левую кнопку мыши и, удерживая её, 
перетащить курсор на значок нужного альтернативного инстру-
мента. 
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Рис. 4. Инструменты основной палитры 

Панель (палитра) параметров (Options) (рис. 5). Здесь 
отображаются все изменяемые настройки инструментов. Данная 
панель меняет вид в зависимости от выбранного инструмента. 
Далее в таблице 2 будут представлены основные инструменты 
графического редактора Photoshop. 
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Рис. 5. Панель параметров для инструмента Marquee
(Прямоугольная область)

Таблица 2

Инструменты выделения, перемещения и обрезки
Данная группа представляет 
собой инструменты, которые 
осуществляют геометрическое 
выделение: 
Marquee - Прямоугольная об-
ласть выделяет области пря-
моугольной формы. 
Ellipticalmarquee - Овальная 
область - выделяет области 
овальной формы.
Singlerowmarquee - Область 
(горизонтальная строка) -
производит выделение гори-
зонтальной полосы толщиной 
в 1 пиксел.
Singlecolumnmarquee - Об-
ласть (вертикальная строка) 
производит выделение верти-
кальной полосы толщиной в 1 
пиксел. 
Группа свободного выделения. 
Lasso - Лассо - выделяет всю 
обведенную область.
Polygonallasso - Многоуголь-
ное лассо - строит границу вы-
деления мелкими шагами в ви-
де прямых отрезков.
Magneticlasso - Магнитное 
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лассо - строит выделение на 
основе цветовой разности. 
Magicwand - Волшебная па-
лочка - выделяет область пик-
селов по их цветовой схоже-
сти. Основным параметром яв-
ляется Tolerance (Допуск), за-
дает степень близости цвета 
пикселов, необходимую для 
добавления их в выделение. 
Crop - Рамка - обрезает изо-
бражение до указанной облас-
ти. 
Slice - Фрагмент - применяет-
ся для разрезания изображения 
на куски и последующей оп-
тимизации для использования 
в Интернете. 

Инструменты рисования и ретуширования
Группа инструментов предна-
значена для ретуширования 
изображений. 
HealingBrush - Лечащая кисть
- осуществляет текстурную 
коррекцию с учетом подлож-
ки. 
PatchTool - Заплатка - соче-
тание произвольного выделе-
ния и заливки. 
Brush - Кисть - прямое рисо-
вание активным цветом. 
Группа инструментов предна-
значена для фотомонтажа. 
CloneStamp - Штамп - неза-
менимый инструмент при фо-
томонтаже. Действует сле-
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дующим образом: укажите 
мышью (с нажатой клавишей 
Alt), из какого места на изо-
бражении перерисовывать, за-
тем просто водите кистью в 
том месте, где необходимо по-
вторить выбранный фрагмент.
PatternStamp - Фигурный 
штамп - позволяет рисовать 
текстурой. 
HistoryBrush - Кисть состоя-
ния - позволяет рисовать из 
любого места истории.
ArtHistoryBrush - Художест-
венная восстанавливающая 
кисть - восстанавливает со-
стояние изображения из сним-
ка истории и позволяет приме-
нять различные художествен-
ные эффекты. 
Eraser - Ластик - позволяет 
удалять кусочки изображения. 
BackgroundEraser - Фоновый 
ластик - ластик, предназна-
ченный для отделения объекта
от фона.
MagicEraser - Волшебный 
ластик - выделяет область, а 
затем удаляет ее. 

Инструменты заливки
Gradient - Градиент - создает 
заливку с плавным переходом 
между двумя или несколькими 
цветами. 
PaintBucket - Заливка - зали-
вает изображение цветом или 
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текстурой. 
Инструменты коррекции изображения

Blur - Размытие - инструмент 
для размытия участка изобра-
жения. 
Sharpen - Резкость - увеличи-
вает контрастность области. 
Smudge - Палец - создает эф-
фект, похожий на размазыва-
ние пальцем еще не высохшей 
краски на полотне. 
Dodge - Осветлитель - изме-
нение яркости пикселов в сто-
рону увеличения, что приводит 
к осветлению изображения. 
Burn - Затемнитель - измене-
ние яркости пикселов в сторо-
ну уменьшения, что приводит 
к затемнению изображения. 
Sponge - Губка - изменяет на-
сыщенность цвета в редакти-
руемой области. 

Инструменты ввода текста, создания контуров и фигур
Type- Текст - горизонтальный 
текст, цвет которого определя-
ется цветом переднего плана 
(ForegroundColor).
VerticalTypeTool - текст в 
вертикальном направлении.
HorizontalTypeMaskTool -
писать выделением.
VerticalTypeMaskTool - текст 
как выделение в вертикальном 
направлении
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Pen - Перо - инструмент, кото-
рый создает контуры.
FreeformPen - Свободное Пе-
ро - инструмент, ближайшим 
аналогом которого является 
Lasso (Лассо), однако данный 
инструмент создает контур, а 
не выделение.
AddAnchorPoint - Перо+ - до-
бавить опорную точку конту-
ра. 
DeleteAnchorPoint - Перо- -
удалить опорную точку.
ConvertPoint - Угол - инстру-
мент для модификации конту-
ра. 
Данная группа позволяет бы-
стро и легко создавать двух-
мерные геометрические фигу-
ры. 
Rectangle – Прямоугольник
RoundedRectangle - Скруглен-
ный прямоугольник
Ellipse – Эллипс
Polygon – Многоугольник
Line – Линия
CustomShape - Пользователь-
ская фигура. В данном списке
содержатся фигуры, созданные 
вручную. При помощи коман-
ды Edit ->DefineCustomShape 
(Редактирование> Определить 
новую фигуру) пользователь 
может сохранить любой кон-
тур как фигуру и использовать 
ее в дальнейшем. 
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PathSelection - Перемещение 
фигур - применяется для пере-
мещения фигур. 
DirectSelection - Модификация 
фигур - инструмент, при по-
мощи которого можно менять 
вид фигуры путем воздействия 
на точки и линии контура, ог-
раничивающего фигуру. 

Инструменты для вставки пометок
Notes - Пометка - инструмент, 
предназначенный для создания 
текстовых пометок в работах. 
AudioAnnotation - Аудиоза-
пись - инструмент, предназна-
ченный для создания звуковых 
пометок в работах.

Измерительные инструменты
Eyedropper - Пипетка - по-
зволяет сделать цветом перед-
него плана (ForegroundColor) 
цвет того пиксела, по которо-
му пользрватель щелкает этим 
инструментом в данный мо-
мент.
ColorSampler - Выбор цветов
- позволяет делать активными 
не один, а несколько цветов.
Measure - Линейка - использу-
ется для измерения расстояний 
и углов. 

Инструменты управления просмотром
Hand - Рука - позволяет дви-
гать изображение в пределах 
экрана. 
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Zoom - Масштаб - масштаби-
рование изображения. 

Инструменты выбора цветов и режима
1. SetForegroundColor - Ус-
тановить цвет переднего 
плана. 
2. SetBackgroundColor - Ус-
тановить цвет заднего плана. 
3. DefaultForegroundand
BackgroundColors - Устано-
вить цвет по умолчанию.
4. SwitchForegroundand
BackgroundColor - Поменять 
местами цвета переднего и 
заднего плана. 
EditinStandardMode - Рабо-
тать в обычном режиме - все 
инструменты работают так, 
как и должны работать по сво-
ему назначению. 
EditinQuickMaskMode - Ре-
дактировать быструю маску. 
Быстрая маска существует для 
однократного применения и не 
сохраняется на протяжении 
всей работы.

3. ПРИМЕР ВЫПОЛНЕНИЯ РАБОТЫ

Для построения коллажа нам понадобятся 3 изображения: 
два изображения неба и фотография девушки. Загрузите изобра-
жение Cloud1 и Cloud2. 
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Рис. 3.1. Cloud1 

Рис. 3.2. Cloud2 

Скопируйте Cloud2: Edit ->Copy (Редактирование -> Копи-
ровать) или Ctrl+C, и вставьте в изображение Cloud1, выполнив 
команду Edit ->Paste (Редактирование -> Вставить) или Ctrl+V. 
Подгоните размер Cloud2 под размер Cloud1, для чего выполните 
команду: Edit ->Transform ->Scale (Редактирование -> Трансфор-
мация -> Масштаб). 
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Убедитесь, что активен верхний слой. В палитре Layers 
(Слои) выставьте режим наложения слоя PinLight. Должен полу-
читься эффект, представленный на рис. 3.3. Склейте слои. 

Рис. 3.3. Изображение после наложения слоя в режиме PinLight

Загрузите изображение Girl (рис. 3.4). С помощью удобного 
для вас инструмента выделите девушку, скопируйте и вставьте в 
только что полученное изображение неба. 

Рис. 3.4. Girl
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Разместите девушку справа таким образом, чтобы было за-
нято 2/3 фона. Увеличьте изображение с помощью команды Edit -
>Transform ->Scale (Редактирование -> Трансформация -> Мас-
штаб). Обработайте края изображения с помощью инструмента 
Blur (Размытие). Установите параметр Opacity (Непрозрачность) 
48 %. Склейте слои. 

С помощью инструмента HorizontalType (Горизонтальный 
текст) напишите фразу. Шрифт выберите на свой вкус. Произве-
дите растеризацию слоя, для чего откройте палитру Layer (Слой) 
и щелкните правой кнопкой мыши по слою с текстом. В появив-
шемся меню выберите пункт RasterizeLayer (Растрировать слой). 
Затем склейте его с нижним слоем. Выделите текст волшебной 
палочкой, для чего выделите одну букву, затем щелкните по вы-
делению правой клавишей мыши и выберите пункт Similar (По-
добно). Примените к тексту инструмент Gradient (Градиент). Вид 
градиента - линейный. 

Итоговое изображение представлено на рис. 3.5.

Рис. 3.5. Итоговое изображение 
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4. ПОРЯДОК ВЫПОЛНЕНИЯ РАБОТЫ

1. Изучить основы теории растровой графики.
2. Изучить основы работы в Photoshop.
3. Разобрать способ выполнения коллажа.
4. Выбрать произвольные изображения и построить свой 

коллаж.

5. КОНТРОЛЬНЫЕ ВОПРОСЫ.

1. Опишите основные особенности растровых файлов
2. Опишите основные возможности Photoshopпо работе с 

�масками¤.
3. Опишите основные возможности Photoshopпо работе с за-

ливками
4. Опишите основные возможности Photoshop, позволяющие 

делать коллажи

СПИСОК РЕКОМЕНДУЕМОЙ ЛИТЕРАТУРЫ

1. Мак-Клелланд, Д. Photoshop CS. Библия пользователя // 
М.: Диалектика, 2006 г. 944с. 
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ЛАБОРАТОРНАЯ РАБОТА №2 
РЕДАКТИРОВАНИЕ РАСТРОВЫХ ИЗОБРАЖЕНИЙ

СРЕДСТВАМИ PHOTOSHOP

Цель работы: освоить приемы обработки растровой графи-
ки, применяя программу Photoshop.

1. РАБОТА СО ШРИФТОМ. ТЕКСТОВЫЕ ЭФФЕКТЫ

Работа со шрифтом - интересная, многоплановая и доста-
точно сложная часть работы в компьютерном дизайне. Поэтому 
стоит рассмотреть различные дизайнерские приемы в создании 
текстовых эффектов. 

В данном методическом руководстве будут описаны прак-
тические приемы работы с текстом

1.1. Надпись огнем

Создайте файл произвольного размера (Ctrl+N). При этом 
проследите, чтобы цвет фона был черный, а в качестве цветовой 
модели (ColorMode) выбранаGrayscale (Полутоновый). Напишите 
текст hot белым цветом, шрифт ArialBold. 

Если вас не устраивает размер или расположение надписи, 
то текст можно отредактировать прямо в окне изображения. Для 
этого нажмите сочетание клавиш Ctrl+T. Откроется окно, в кото-
ром устанавливается размер букв, положение надписи и ее на-
клон. 
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Отредактировав текст, откройте палитру Layers (Слои). Ва-
ше изображение должно содержать два слоя: фоновый слой и 
слой с текстом. Переведите текст в растр. Склейте слой с текстом 
и слой фона, для чего выполните команду Layer -->MergeLayers 
(Слой -->Склеить слои) или нажмите сочетание клавиш Ctrl+E. 

Рис. 1.1. Исходный текст 

Поверните изображение на 90? против часовой стрелки: 
Image ->RotateCanvas -> 90 CCW (Изображение -> Повернуть 
холст -> 90 градусов против часовой стрелки). 

Примените фильтр Wind (Ветер): Filter ->Stylize ->Wind 
(Фильтр -> Стилизация -> Ветер) (рис. 1.2). Установите следую-
щие настройки фильтра: Method (Метод) - Wind (Ветер), Direction 
(Направление) - FromtheRight (Ветер справа). Для того, чтобы 
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применить данный фильтр, и необходимо было вращать изобра-
жение. 

Чтобы увеличить язычки пламени, этот фильтр стоит при-
менить несколько раз. 

Теперь примените к изображению фильтр Glass (Стекло): 
Filter ->Distort ->Glass (Фильтр -> Деформация -> Стекло) (рис. 
1.3). Установите следующие параметры: Distortion (Искажение) 1, 
Smoothness (Смягчение) 3, Texture (Текстура) Frosted, Scaling 
(Неравномерность) 100%. 

Верните изображение в исходное положение: Image -
>RotateCanvas ->90 CW (Изображение -> Повернуть холст -> 90 
градусов по часовой стрелке). 

Рис. 1.2. Диалоговое окно фильтра Wind (Ветер) 

Теперь нужно придать пламени движения. Для этого вос-
пользуйтесь фильтром Ripple (Рябь): Filter ->Distort ->Ripple 
(Фильтр -> Деформация -> Рябь). Установите средний (Medium) 
размер ряби (Size) и сделайте параметр Amount (Эффект) равным 
100% (рис. 1.5). 
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Пришло время раскрасить пламя. Переведите изображение в 
режим индексированных цветов: Image ->Mode ->IndexedColor 
(Изображение -> Режим -> Индексированные цвета). Затем Image 
->Mode ->ColorTable (Изображение -> Режим -> Палитра). Выбе-
рите таблицу BlackBody. 

Рис. 1.3. Диалоговое окно фильтра Glass (Стекло) 
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Рис. 1.4. Текст после применения фильтра Glass (Стекло) 

Рис. 1.5. Диалоговое окно фильтра Ripple (Рябь)

Готовый эффект показан на рис. 1.6. 
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Рис. 1.6. Огненная надпись

1.2. Пишем льдом

Создайте заготовку произвольного формата в режиме 
Grayscale (Полутоновый). Цвет фона должен быть белым, а цвет 
переднего плана - черным (данные цвета являются основными 
цветами по умолчанию, поэтому их можно установить, не пере-
ходя в цветовую палитру, нажатием клавиши D). 

Напишите текст frost, шрифт Century

Рис. 2.1. Исходная надпись
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Откройте палитру Layer (Слой) и щелкните правой кнопкой 
мыши по слою с текстом. В появившемся меню выберите пункт 
RasterizeLayer (Растрировать слой). Затем склейте его с нижним 
слоем. Выделите текст волшебной палочкой, для чего выделите 
одну букву, затем щелкните по выделению правой клавишей 
мыши и выберите пункт Similar (Подобно). 

Выполните кристаллизацию надписи: Filter ->Pixelate -
>Crystallize (Фильтр -> Оформление -> Кристаллизация) (рис. 
2.2). Установите размер ячейки кристаллизации равным 10. 

Так как ледяная поверхность не идеально гладкая, придадим 
ей шероховатость. 

Рис. 2.2. Диалоговое окно фильтра Crystallize 
(Кристаллизация)
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Рис. 2.3. Диалоговое окно фильтра AddNoise 
(Добавить шум)

Для этого следует добавить шум: Filter ->Noise ->AddNoise 
(Фильтр -> Шум -> Добавить шум) (рис. 2.3). Задайте значение 
Amount (Эффект) равным 70 % и установите флажок 
Monochromatic (Монохромный). После выполнения вышеописан-
ных действий должен получиться результат, изображенный на
рисунке 2.4. 

Рис. 2.4. Надпись после кристаллизации и добавления шума 
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Смягчите эффект, полученный после кристаллизации и до-
бавления шума, применив фильтр GaussianBlur: Filter ->Blur -
>GaussianBlur (Фильтр -> Смазывание -> Смазывание Гаусса). 
Радиус размытия возьмите около 2. 

Следующий этап - цветокоррекция с использованием тоно-
вых кривых. 

Выберите команду Image ->Adjustments ->Curves (Изобра-
жение -> Регулировки -> Кривые) или нажмите сочетание клавиш 
Ctrl+M. Попытайтесь нарисовать кривую, похожую на ту, кото-
рая изображена на рис. 2.5. 

Рис. 2.5. Кривая, примененная в примере 

Теперь следует создать сосульки. Для этого выберите снача-
ла команду Image ->RotateCanvas -> 90 CW (Изображение -> По-
вернуть холст -> 90 градусов по часовой стрелке), а затем Filter -
>Stylize ->Wind (Фильтр -> Стилизация -> Ветер). Настройка 
фильтра Wind (Ветер): Method (Метод) - Wind (Ветер), Direction 
(Направление) - FromtheRight (Ветер справа). 
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Рис. 2.6. Текст после применения фильтра Wind (Ветер) 

Верните холст в исходное положение командой Image -
>RotateCanvas -> 90 CCW (Изображение -> Повернуть холст -> 90 
градусов против часовой стрелки). 

Теперь осталось раскрасить лед. Переведите изображение в 
цветовой режим RGB: Image ->Mode -> RGB Color (Изображение 
-> Режим -> RGB). Теперь выберите команду меню Image -
>Adjustments ->Hue / Saturation (Изображение -> Регулировки -> 
Цвет / Насыщенность). Установите флажок Colorize (Тонирова-
ние) и следующие параметры: тон (Hue) 198, насыщенность 
(Saturation) 54, яркость (Lightness) 0. 

Для того, чтобы лед засверкал и заискрился, выберите инст-
румент Brush (Кисть) и активизируйте режим AirbrushCapabilities 
(Возможности аэрографа). Воспользуйтесь дополнительными 
кистями в виде звезд и снежинок для создания эффекта искряще-
гося и переливающегося на солнце льда. 

Итоговое изображение представлено на рис. 2.7. 
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Рис. 2.7. Итоговое изображение 

2. ПОРЯДОК ВЫПОЛНЕНИЯ РАБОТЫ

Изучить основы обработки шрифтов и эффектов
Выбрать произвольный текст и повторить описанные эф-

фекты

3. КОНТРОЛЬНЫЕ ВОПРОСЫ.

1. Опишите основные фильтры, применяемые для работы 

4. СПИСОК РЕКОМЕНДУЕМОЙ ЛИТЕРАТУРЫ

1. Мак-Клелланд, Д. Photoshop CS. Библия пользователя // 
М.: Диалектика, 2006 г. 944с.



34

ЛАБОРАТОРНАЯ РАБОТА № 3. СОЗДАНИЕ АНИМАЦИИ 
С ИСПОЛЬЗОВАНИЕМ ТЕХНОЛОГИИ FLASH

Цель работы: освоить начальные приемы создания анима-
ции, используя программу AdobeFlash

1. ТЕОРЕТИЧЕСКИЕ ПОЛОЖЕНИЯ

1.1. Настройка параметров фильма

Запустив MacromediaFlash, в меню File ->New создаем но-
вый файл,будущий Flash-ролик, которому даем название Спут-
ник, что будет соответствовать цели нашего ролика. 

Перед началом создания ролика, необходимо выставить 
нужные настройки фильма: 

1. FrameRate –это частота кадров до 25fps, для сложной 
графики необходимо уменьшать частоту кадров до 8fps. 
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2. Dimensions–здесь указывается ширина (width) и высота 
(height) кадра в пикселях, по умолчанию это значение равно 
550?400, именно таким будет размер кадров фильма в браузере. 

3. Match –здесь так же можно указать размеры кадра при 
помощи кнопок Printer и Contents. Чтобы узнать размеры кадра 
по размеру изображения в этом кадре, следует нажать кнопку 
Contents(содержимое). Если же надо сделать размер кадра соот-
ветственно параметрам печати нужно нажать кнопку 
Printer(печать).в секунду, для большинства компьютеров, с учё-
том скорости загрузки с web-сайта, оптимальным значением, 
принятым по умолчанию является 12fps. Если же фильм простой 
и он будет просматриваться на очень быстром компьютере, то это 
значение можно увеличить 

4. Backgroundcolor – цвет фона кадров, по умолчанию это 
белый. 

5. Rulerunits –единицы измерения линейки, которые ото-
бражают размеры кадра на сцене. Выбираются из списка те еди-
ницы, которые нам нужны. По умолчанию линейки выключены, а 
включить их можно при помощи команды меню View->Rulers . 

Для применения выставленных параметров, нужно нажать 
кнопку SaveDefault.

1.2. Символы и работа с ними

Символы - одно из ключевых понятий во Flash. Символом 
может быть, как простейшая геометрия или их объединение, так 
и целая анимация (movie). Это позволяет использовать символы, 
как мощный механизм создания абстракций во Flash. 

Например, можно сделать символы - колесо, корпус, стекла, 
антенны. Потом все это объединить в символ – автомобиль. А за-
тем создать сцену, на которой этот автомобиль будет ехать. Дру-
гой пример. Допустим, нам нужно нарисовать падающий снег. Я 
создаём символ снежинки, создаём символ, содержащий несколь-
ко анимирующихся снежинок, далее создаём символ в виде стол-
бика падающих снежинок, затем размножаем этот столбик - и по-
лучаем падающий анимирующийся снег на всю сцену. 

Символы добавляют гибкости нашей сцене. В случае с ав-
томобилем я можем сделать колесо анимированным символом, 
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так, чтобы ощущалось вращение. Можем сделать дверь кнопкой, 
чтобы при клике мышкой она открывалась. Смысл в том, что в 
любой момент я можем изменить содержание и вид символа, что 
существенно сокращает затраты на модификацию Flash сцен. 

Существует три вида символов: анимация (movieclip), кноп-
ка (button) и изображение (graphic): 

Изображение (graphic), представляет собой символ, состоя-
щий из единственного кадра. Отсюда следует его статичное на-
звание. Если символ действительно представляет собой статич-
ный (не анимирующийся) объект, лучше сделать его изображени-
ем (graphic). 

Кнопка (button). Во Flash есть специально приспособленный 
под функции кнопки вид символа. В нем имеется 4 кадра: Up, 
Over, Down, Hit, которые содержат следующие состояния кнопок: 

 Up- обычное состояние кнопки.
 Over - когда курсор мышки находится над кнопкой.
 Down - когда курсор находится над кнопкой и нажата кла-

виша мыши.
 Hit - обычное состояние, для кнопки, содержащей ссылку, 

которую пользователь уже посещал.
Анимация (movieclip). Это самый "полноценный" тип сим-

вола. В нем может быть любое количество кадров. Символ этого 
типа может восприниматься как объект типа Movie в ActionScript 
(это встроенный язык Flash). 

Символы могут быть вложенными вне зависимости от типа. 
Это является самым главным их достоинством. Например, можно 
сделать кнопку, которая начнет двигаться, когда над ней будет 
"пролетать" курсор мыши, просто поместив в кадр Over символ -
анимацию. Или на изображение поместить бегущую кошку. Все 
остальное - дело вашей фантазии. Символы можно создавать как 
"с нуля" (Insert->NewSymbol, Ctrl+F8), так и используя текущее 
выделение, поместив его сразу в символ (Insert-
>ConverttoSymbol, F8). Второй прием используется гораздо чаще, 
чем первое, т.к. в этом случае отпадает надобность его позицио-
нировать и изнасть под нужный размер. Для управления симво-
лами используется так называемая библиотека (Library). 

Теперь создаем эталон спутника. Для этого нам потребу-
ется зайти в меню Insert->NewSymbol, после чего у нас появится 
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окно –SymbolProperties, в котором нам нужно будет указать 
Name(имя) и Behavior(поведение) создаваемого символа. Назовем 
его Спутник, а второе свойство оставим нетронутым. 

После этого закрываем это окно, и программа входит в ре-
жим редактирования эталона - Спутник. 

Спутник мы решили изобразить в виде небольшого шара, и 
для этого нам понадобится воспользоваться инструментом Oval и 
выставить для этого инструмента Properties (свойства): Fillcolor 
(цвет заливки), и Strokecolor(контура). Для того чтобы наш спут-
ник выглядел более реально, воспользуемся в Fillcolor, градиент-
ной заливкой (она обычно используется для имитации 3D-
объектов). 

Выбираем серую градиентную заливку, это самый нижний 
ряд в палитре цветов заливки вторая по счёту, а контур делаем 
бесцветным, т.е. NoСolor в панели инструментов.
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Далее в окне Info изменим размер нашего эталона на мень-
ший, в данном случае это 30x30.

Для того чтобы объектом дальше было легче управлять, 
центр нарисованного круга должен точно совпадать с точкой 
привязки в центре сцены. Это можно сделать, выделив объект 
инструментом Arrow, а потом либо перетащив объект при помо-
щи мыши, либо при помощи клавиатурных стрелок управления 
курсором (что позволит более точно перетащить объект к привяз-
ке). Эталон спутника создан, переходим к следующему шагу.

1.3. Работа с графическими объектами

Теперь создаем графический объект – планету и эллипти-
ческую орбиту, в режиме редактирования сцены. Для этого с на-
чала, в зависимости от размера монитора, нужно изменить мас-
штаб, применённый к сцене, это можно сделать либо посредст-
вом вкладки меню View->Magnification->нужный масштаб, либо 
при помощи ниспадающего меню в нижнем левом углу окна на-
шего фильма. 

Планету мы решили представить так же в виде круга, но 
уже большего размера, чем спутник, и без контура и залить гра-
диентной заливкой. 

После того, как мы создали объект планеты, выделив его, 
изменяем размер и цвет его заливки с серого на синий. Это мож-
но сделать с помощью пункта меню Window->Panels->Fill, а да-
лее в окне Fill и одноимённой вкладке убедимся, что выставлен 
именно RadialGradient(радиальный градиент), что будет 
больше имитировать планету. После чего изменим порог гради-
ента, при помощи маркеров градиента. 
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Порог—это точка расположения сплошного цвета. 
Промежутки между порогами заполняются цветовым переходом. 
Пороги представлены в виде маркеров разных цветов, в данном 
случае белого и чёрного. Сначала мы изменим цвет чёрного мар-
кера на сине-голубой и белого на светло-жёлтый, а потом цвето-
вой переход, работая всё с теми же маркерами. 

1.4. Слои и анимация с движением (MOTION TWEENING)

Теперь приступаем к созданию объекта эллиптической ор-
биты. Она у нас будет представлена в виде опять таки овала, но 
уже без заливки и с контуром синего цвета, после чего у нас по-

лучается следующее: 
После того, как мы создали 

эллиптическую орбиту, которая 
расположена по центру нашей 
планеты, планета разделилась 
на сектора. Это произошло из-за 
того, что в технологии-Flash 
объекты делятся на сектора в 
точках их пересечения. Данная 
особенность сначала может по-

казаться неудобной, но в последствии при создании более слож-
ных роликов просто необходима. Нам же для избежания такого 
разделения планеты и орбиты на сектора нужно всего лишь сде-
лать двойной щелчок на нужном объекте, а потом воспользо-
ваться пунктом меню Modify->Group (или комбинацией клавиш 
Ctrl+G). Команда Group позволяет сгруппировывать объекты 
или объекты в одно целое. Для отмены этой команды надо сде-
лать разгруппировкуModify->Ungroup (или комбинацией кла-
виш Ctrl+Shift+G).

Сгруппировав отрезки нашей орбиты, вокруг неё появился 
прямоугольник – это означает что команда группировки выпол-
нена, если бы этого не произошло, то пришлось бы повторять 
операцию. 

Выполнив группировку, выделим орбиту и планету одно-
временно (стрелкой мыши кликая на объектах, держа нажатой 
клавишу Shift), и выровним их по центру, открыв для этого окно 
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выравнивания комбинацией клавиш Ctrl+K или выбрав пункт 
меню Window->Panels->Align. В этом окне можно увидеть мно-
жество различных выравниваний, но нам понадобятся лишь два 
из них: AlignHorizontalCenter и AlignVerticalCenter.

Выровняв свои объекты, снимем выделение с планеты, оста-
вив его на орбите, и на панели инструментов в разделе Options 
нажав на кнопку Rotate –(Вращение) или же выбрав пункт меню 
Modify->Transform->Rotate после чего у нас по контуру прямо-
угольника появляются маркеры. Маркеры - по углам для враще-
ния, по центру для наклона. Теперь, используя маркеры по уг-
лам, повернем орбиту примерно на 450, что сделает её более 
правдоподобной. 

Теперь разгруппируем орбиту и удалим верхнюю её часть, 
которая находится в области планеты: 
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1.5. Слои и анимация с движением

В MacromediaFlash все объекты расположены на слоях. 
В компьютерной графике этот инструмент используется очень 
часто. Представьте, что вы рисуете на прозрачных листах, а по-
том накладываете их друг на друга. То, что находится на верхних 
слоях, закрывает содержимое нижних слоев. Слои можно делать 
невидимыми и/или недоступными, чтобы облегчить редактиро-
вание сцены в целом. 

Во Flash есть пара особенных типов слоев: слои, содержа-
щие траектории движения и слои - маски. Есть достаточно боль-
шое количество приемов, в которых используются слои, но во 
Flash без них просто нельзя обойтись по одной важной причине: в 
один момент времени для каждого объекта анимации нужен от-
дельный слой. Объектом анимации считается фигура (shape) или 
символ (symbol). 

На начальном этапе по умолчанию у нас всегда содержится 
один слой Layer1. Давайте сначала рассмотрим вкратце всю вре-
менную шкалу: 

Рис. 1 - Временная шкала
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Маркер - указывает на текущий кадр, отображаемый в окне. 
При клике на какой-либо кадр, маркер автоматически перемеща-
ется на него. 

Слои - слева находится перечень слоев. Под ним существу-
ют кнопки, позволяющие добавлять и удалять слои. Каждый слой 
можно сделать невидимым и запретить его для редактирования. 

Шкала кадров - поле, где вы можете добавлять и удалять 
простые и ключевые кадры. Если вызвать контекстное меню (на-
жать на правую клавишу мыши) на каком-либо кадре, вы увидите 
перечень действий, которые можно совершить. На шкале ото-
бражается информация о кадрах, которые являются ключевыми 
(такие кадры помечаются черными кружочками), содержат дей-
ствия (буковка "а" над кружочком) или метку (красный флажок, 
после которого идет название метки). Цвет тоже говорит о типе 
кадров. Серый цвет - это кадры, которые в точности повторяют 
ключевой кадр (keyframe). Синеватая или зеленоватая подсветка 
говорит о том, что кадры сгенерированы Flash (о различиях мы 
расскажем ниже). И, наконец, белое или "пустое" полосатое про-
странство говорят о том, что на этих кадрах ничего нет. 

Кнопки управления тенями - это кнопки, позволяющие 
отображать соседние кадры как бы через кальку, чтобы видеть 
разницу между предыдущими и последующими кадрами. Можно 
задавать глубину такого отображения по обе стороны от маркера. 

Теперь мы изменим название слоя с Layer1 на Планету, это 
будет тот слой на котором будет отображаться планета. 

Потом создадим второй слой и назовем его Орбита, после 
этого на слое Планета выделим орбиту и нажмем Ctrl+X, вырезав 
орбиту, выделим слой Орбита и выбрав из пункта меню команду 
Edit ->PasteinPlace или Ctrl+Shift+V, вставим орбиту на тоже ме-
сто, откуда вырезали, но уже на одноимённом слое.

Фильм воFlash представляет собой последовательность кад-
ров, которые выполняются по мере их расположения на шкале 
времени. Пока анимация не создавалась на шкале времени в каж-
дом слое, есть только один кадр. Кадры обозначены на шкале 
времени тонкими серыми полосочками. Переходить с кадра на 
кадр можно воспользовавшись проигрывающей головкой, она 
отмечена красным цветом на шкале времени над кадрами и пере-
секает все слои сразу. 
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Анимация во Flash бывает двух видов покадровая 
(FramebyFrame) и расчётная (Tweenanimation). 

Если в покадровой анимации мы создаём каждый кадр от-
дельно, то в расчётной мы генерируем промежуточные кадры 
между начальным кадром и конечным. Расчётная анимация быва-
ет двух видов анимация движения -motiontweening и анимация 
форм -shapetweening

Создадим ещё один слой и назовем его Спутник, затем от-
кроем панель Библиотеки, и нажав левой кнопкой мыши на сим-
воле спутника перетащим его на этот слой, но так, чтобы его 
центр совпал с концом орбиты, Для того, чтобы это сделать более 
точно, необходимо отключить слой Планета. 

После выполненных действий, у нас на слое Спутник, поя-
вится ключевой кадр. Теперь займемся движением спутника по 
орбите. Выделим спутник, выберем в пункте меню Window -
>Panels ->Frame или нажмем Ctrl+F, после чего перейдем на 
вкладку Frame. 

В этой вкладке можно выставить свойства для спутника 
следующие:

Label –Метка
Tweening -построение промежуточных отображений
o None –отсутствие анимации
o Motion - При этом способе анимации Flash автоматически 

строит промежуточные кадры между ключевыми кадрами, задан-
ными вами. Это означает, что вы рисуете объект, потом на дру-
гом кадре производите изменения, о которых мы поговорим ни-
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же, и просите Flash рассчитать те кадры, которые лежат между 
этими двумя ключевыми кадрами. Он выполняет эту работу, и вы 
получаете плавную анимацию.

o Shape -Скажем, вам нужно, чтобы квадрат плавно превра-
тился в круг, или силуэт кролика плавно перетек в силуэт волка

Scale (on/off) –Масштабировать
Easing –Ускорение
Rotate –Вращение и поле ввода для количества оборотов.
Orient to path (on/off) –Движениепотраектории
Synchronize (on/off) –Синхронизация
Snap (on/off) –Привязка
Для спутника метку писать не нужно, выберем 

motiontweening, ускорение и вращение оставляем, как было вы-
ставлено по умолчанию, и далее лишь выставляем галочки в по-
лях масштабирования, движения по траектории, синхронизации и 
привязки. Сохраняем изменения Ctrl+S или File ->Save. 

После сделанных изменений для спутника, на всех слоях 
выделим 66-й кадр и сделаем его ключевым, нажав F6. Если по-
смотреть теперь на слои, то можно увидеть, что кадры на слоях 
Орбита и Планета заполнены серым цветом, а Спутника сирене-
вым со стрелочкой протянутой с 1-го по 66-й. Это означает, что с 
помощью выставленных только что свойств для спутника, было 
сгенерированно его движение. Сейчас мы должны перейти на 66-
й кадр на слое 

Спутник и выделив спутник, переместить его на другой ко-
нец орбиты. Ну и самое интересное, проверка созданной анима-
ции! Для этого выберем из пункта меню Window ->Toolbars -
>Controller и после появления контроллера нажимаем на клавишу 
пуск (она изображена в виде стрелочки вправо), чтобы его оста-
новить, нужно нажать на кнопку стоп (она изображена в виде за-
полненного квадрата). 

Идём дальше, выделим слой Спутник и добавим над ним с 
помощью такой кнопки на временной шкале или пункта меню 
Insert ->MotionGuide, направляющий слой. Он будет назван в за-
висимости от слоя, находящегося под ним, в данном случае 
Спутник, а обычный слой под ним будет сдвинут немного впра-
во. Теперь на этот слой скопируем орбиту, так же, как копирова-
ли её со слоя Планета на слой Орбита. После этой операции на 
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направляющем слое будут заполнены все кадры, начиная с 1-го 
по 66-й. Это должно выглядеть следующим образом: 

1.6. Маштабирование

Чтобы сделать движение спутника по орбите, следует сде-
лать так, чтобы спутник заходя за Планету исчезал, а когда появ-
лялся, увеличивался в размерах по мере его расположения на ор-
бите. Но так как при анимации в плеере цикл движений повторя-
ется непрерывно, следует сделать некую приостановку между 
циклами так, чтобы спутник на некоторое время задержался за 
планетой, прежде чем снова появится вначале орбиты. И так во 
временную шкалу добавим в начало каждого слоя ещё по 4 кадра. 
Для этого нужно переместить проигрывающую головку в начало 
шкалы времени и 4 раза нажать на кнопку F5. Таким образом, 
проигрывающая головка переместилась на отметку 5. Теперь вы-
делив слой Спутник, переведем проигрывающую головку на от-
метку 5 и нажмем F6, таким образом содержимое нового кадра 
получает копию содержимого ближнего кадра слева, т.е 1-го 
ключевого. Тоже самое делаем с последним кадром, т.е. ставим 
проигрывающую головку за 5 кадров до последнего и нажимаем 
F6. Теперь возвращаемся к первому кадру и в окне Info выставля-
ем размер спутника 0?0, тоже самое проделываем с последним 
кадром. Вот что у нас должно было получиться:
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Так же можно сделать ещё несколько ключевых кадров для 
того, чтобы, например, спутник по мере приближения к центру 
орбиты постепенно увеличивался, а потом снова уменьшался. Мы 
сделали это следующим образом: установили проигрывающую 
головку в ту отметку, где спутник находится почти по центру ор-
биты и планеты, и вставили новый ключевой кадр, на котором 
спутник изменяет свой размер с 34 на 60. Потом через 4 кадра 
вставляли ключевые кадры, сначала справа, уменьшая размер 
спутника с 60 до 55, потом 55 до 50 и т.д. до тех пор, пока не 
дошли до 34, а потом так же в обратную сторону. Вот так: 
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1.7. Анимация Форя (SHAPE TWEENING)

На этом шаге мы займемся анимацией форя, для того чтобы 
создать впечатление вращения планеты вокруг своей оси. В этом 
случае сама планета передвигаться не будет, а будет изменяться 
лишь её форма, цвет, расположение или размер. 

Начинаем с блокировки всех слоёв, кроме слоя Планеты, 
для того чтобы случайно не повредить их. Выделив планету, от-
крываем окно Frame (Ctrl+F) и в одноимённой вкладке выставля-
ем вид анимации форя: ShapeTweening. 

Далее на шкале времени, на слое Планета появилась стре-
лочка зелёного цвета вдоль всех кадров. Зелёный цвет означает, 
что в данном случае применена именно анимация форя. Теперь 
устанавливаем проигрывающую головку на первый ключевой 
кадр и выбираем на панели инструментов заливку, внизу в свой-
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ствах выбираем TransformFill . При нажатии левой кнопки 
мыши на планете, появляется следующее: 

Теперь для создания визуального эффекта, что планета вра-
щается вокруг своей оси, мы решили воспользоваться самым 
простым, но очень оригинальным способом. С помощью маркера 
в центре планеты, мы модифицируем её градиент в первом и по-
следнем кадре. Итак, мы переводим проигрывающую головку на 
первый кадр и с помощью маркера выносим градиент за пределы 
планеты и переносим его влево. Необходимо сделать это так, 
чтобы его центр соответствовал центру планеты и орбиты, и что-
бы контур градиента и контур планеты были на одной прямое, 
если включить сетку.



49

То же самое мы делаем и для последнего кадра, только гра-
диент переносим уже влево, с теми же условиями что и на пре-
дыдущем этапе. 
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1.8. Озвучание фильма

На этом шаге мы займемся озвучиванием нашего анимаци-
онного фильма. 

Для того, чтобы во время вращения спутника по орбите и 
планеты вокруг своей оси, нам необходимо сначала создать но-
вый слой, на котором будет расположен звуковой фрагмент, вос-
производимый при проигрывании ролика. Новый слой мы назо-
вем Звук, и расположим его в самом верху. Теперь для того, что-
бы включить в свой фильм звук, нам необходимо воспользовать-
ся библиотекой звуков или импортировать свой собственный 
файл. Программа Flash позволяет импортировать файлы сле-
дующих форматов: MP3 (MPEG-1 AudioLayer 3), WAV 
(WindowsWave), AIFF или AIF (AudioInterchangeFileFormat), 
QuickTime (к сожалению, аудиофайлы QuickTime с расширением
.QTA или .MOV, нельзя непосредственно импортировать в про-
грамму Flash. Однако, эти аудиофайлы можно подготовить для 
импортирования во Flash, сохранив их в формате WAV или AIFF. 
Для этого следует установить на компьютере программу 
QuickTimePro 4.0 или выше, её можно найти на Web-узле Apple 
по адресу www.apple.com ) Так как наш анимационный фильм 
предназначен для Web, то необходимо к нему подобрать что-то 
привлекательное и современное. Мы предпочли импортировать 
файл Moby –“Imyheart” формата mp3, что как нам кажется, иде-
ально подходит для данного ролика. 

Теперь мы займемся его интеграцией в фильм. Но сначала, 
проверим, есть ли в библиотеке фильма только что импортиро-
ванный файл. Для этого выберем пункт меню Window ->Library, 
после этого у нас откроется окно со всеми экземплярами, в том 
числе и с импортированным музыкальным файлом, где можно 
будет прослушать и просмотреть всё содержимое библиотеки 
создаваемого фильма. Далее выбрав из пункта меню Window -
>Panels ->Sound, появится окно, в котором мы приступим к вне-
дрению нашего музыкального файла в ролик. 

�� ������ www.apple.com )
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Sound – в этом ниспадающем меню будут показываться все 
музыкальные файлы, которые содержатся в библиотеке нашего 
фильма. В данном случае будет две строки, None-музыка будет 
отсутствовать, и MOBY “InmyHeart”, мы выбираем второе. 

Effect – это способы обработки звука программы Flash. 
o None –отсутствие 
o LeftChannel/RightChannel (Левый канал/ Правый) –

воспроизводится только левый или правый канал для стереозву-
ка. 

o FadeLefttoRight/ FadeRighttoLeft (Затухание с переходом 
звука слева направо/ или справа налево) –этот эффект понижает 
уровень звука одного канала и увеличивает для другого, создавая 
эффект панорамирования. 

o FadeIn/ FadeOut (Нарастание/ Затухание) –эффект FadeIn 
(нарастание) постепенно повышает уровень от нуля до максиму-
ма в начале звукового клипа, а FadeOut соответственно наоборот. 
По умолчанию этот эффект составляет в процентном соотноше-
нии 25% от общей продолжительности звукового клипа. 

o Custom (Пользовательский) –при изменении уровней или 
маркеров огибающей на экране вручную программа Flash автома-
тически изменяет значение меню Effect на параметр Custom. 

Здесь мы выберем None. 
Sync (от Synchronization — синхронизация) – здесь можно 

выбрать способ синхронизации звука т.е. его соответствия кар-
тинке: 
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o Event - звук синхронизируется посредством привязки его к 
определенным событиям фильма; звук, управляемый событием, 
воспроизводится с момента перехода к соответствующему клю-
чевому кадру, и продолжается независимо от временной шкалы, 
даже если фильм будет остановлен (если, конечно, звук доста-
точно продолжителен); 

o Start — вариант аналогичен предыдущему, за исключени-
ем того, что при очередном наступлении заданного события на-
чинается воспроизведение нового экземпляра звука, даже если 
воспроизведение предыдущего еще не закончено; 

o Stop — эта опция схожа с опцией Start, за исключением 
того, что воспроизведение выделенного звука останавливается 
при наступлении события синхронизации Stop. Эту опцию так же 
можно использовать для остановки воспроизведения определён-
ного звука. 

o Stream — потоковый звук; Flash обеспечивает �насильст-
венную¤ синхронизацию анимации и потокового звука: напри-
мер, если кадры анимации не успевают воспроизводиться на 
Web-странице с той же скоростью, что и потоковый звук, Flash-
плеер пропускает некоторые кадры; воспроизведение потокового 
звука всегда прекращается при завершении анимации; кроме то-
го, потоковый звук никогда не продолжается дольше, чем вос-
производятся связанные с ним кадры анимации. 

Здесь мы выбираем Stop, так как считаем, что для нашего 
ролика лучше всего это подходит. 

Loops (Циклы) –здесь можно установить длительность зву-
чания; она определяется, как число повторений звука; это число 
следует ввести в поле; например, если 3-секундный звук должен 
быть слышен в течение 30 секунд, следует ввести в поле Loops 
число 10. 

Зададим значение 100, т.к. ролик рассчитан на Интернет. 
Теперь проверим, что у нас получилось, но уже не с помо-

щью контроллера, а с помощью пункта меню Control ->TestMovie 
или комбинацией кнопок Ctrl+Enter. 
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1.9. Публикация фильма

Теперь мы займемся публикацией фильма. Сначала мы вы-
ставим нужные нам параметры публикации, для этого воспользу-
емся пунктом меню File->PublishSettings или комбинацией кно-
пок клавиатуры Ctrl+Shift+F12, после чего на экране появится 
следующее окно: 

Оно содержит три вкладки Formats, Flash, HTML. В первой 
вкладке указаны типы файлов, которые можно получить после 
публикации. Мы выберем: .swf, .html, .gif, .exe. Мы можем снять 
галочку в строке Usedefaultnames, что позволит сменить имена 
генерирующихся файлов во время публикации, но нам это не-
важно поэтому мы оставим её без изменений.
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Теперь перейдем к следующей вкладке – Flash. 
LoadOrder (порядок загрузки). Этот параметр определяет 

то, каким образом программа Flash будет отображать первый 
кадр фильма при его загрузке в приложение или проигрыватель. 

o BottomUp (снизу вверх) –слои загружаются в возрастаю-
щем порядке: сначала самый нижний слой, затем последующий.

o TopDown (сверху вниз) –слои загружаются в порядке убы-
вания.

Generatesizereport (Создать отчёт). При установлении 
этого флажка команда Publish (публиковать) экспортирует файл 
.txt для просмотра в текстовом приложении.

OmitTraceactions (отменить действия трассирования).
При выборе этого параметра проигрыватель Flash игнорирует 
любые действия трассировки языка ActionScript.

Protectfromimport (Защита от операции импортирова-
ния). Этот параметр гарантирует меры безопасности для .SWF-
файла в Internet. При установке этого флажка .SWF-файл нельзя 
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импортировать обратно в авторскую среду редактирования Flash 
5 или изменить его каким-либо образом. 

DebuggingPermitted (Разрешить отладку). Если этот фла-
жок установлен, вы можете получить доступ к панели Debugger 
(отладчик) в среде отладки фильма или из Web-браузера, кото-
рый использует встраиваемый дополнительный модуль 
FlashDebugPlayer или соответствующий элемент управления 
ActiveX.

Password (Пароль). Если вы установили флажок 
DebuggingPermitted (Разрешить отладку), то в этом поле можете 
ввести пароль для получения доступа к панели Debugger (Отлад-
чик). 
¨ JPEG Quality (Качество JPEG). Этот ползунок и расположен-
ное рядом текстовое поле определяют уровень сжатия JPEG, ко-
торый принадлежит к растровому изображению в фильме Flash. 

AudioStream (Аудиопоток). Этот параметр отображает 
схему текущего сжатия для потокового сжатия. С помощью 
кнопки Set можно выставить параметры. 

AudioEvent (Аудиособытие). Этот параметр такой же, как и 
предыдущий, но для звуков с синхронизацией типа Event (собы-
тие). 

Overridesoundsettings (Перезаписать параметры звука).
Если необходимо применить параметры AudioEvent и 
AudioStream

соответственно для всех потоковых звуков и звуковых со-
бытий и отменить любую уникальную схему сжатия, заданную 
для конкретного звука в библиотеке Flash, нужно установить этот 
флажок. 

Version (Версия). Здесь можно выбрать версию программы 
Flash для сохраняемого SWF-файла. Лучше выставить версию 
ниже, чтобы можно было смотреть данный фильм во всех верси-
ях, иначе, если просмотреть этот файл, например, в версии 5, а он 
будет сохранён в версии MX, то возникнут некие проблемы. 

В этой вкладке оставим всё без изменений, так же как и в 
следующей вкладке HTML. 

Теперь выберем пункт меню File ->Publish или Ctrl+F12, по-
сле чего произойдёт публикация фильма, и появятся новые фай-
лы с выбранными нами расширениями, т.е. .swf, .html, .gif, .exe. 



56

1.10. Заключение 

Во время создания анимационного фильма, для демонстра-
ции различных видов анимации, мы организовали движение 
спутника вокруг планеты по эллиптической орбите и вращение 
самой планеты вокруг своей оси. Выполнение этой лабораторной 
работы - создание маленького ролика мы решили описать под-
робно по шагам для полного понимания и возможности повто-
рить это любому, кто заинтересуется программой Flash и работе в 
ней. 

Успехов Вам в освоении программы Flash и создании своего 
анимационного фильма. 

ПОРЯДОК ВЫПОЛНЕНИЯ РАБОТЫ

Изучить основы теории растровой графики
Изучить основы работы в Photoshop
Разобрать способ выполнения коллажа
Выбрать произвольные изображения и построить свой кол-

лаж

КОНТРОЛЬНЫЕ ВОПРОСЫ.

1. Опишите основные особенности растровых файлов
2. Опишите основные возможности Photoshopпо работе с 

�масками¤.
3. Опишите основные возможности Photoshopпо работе с за-

ливками
4. Опишите основные возможности Photoshop, позволяющие 

делать коллажи

СПИСОК РЕКОМЕНДУЕМОЙ ЛИТЕРАТУРЫ

1. Мак-Клелланд, Д. Photoshop CS. Библия пользователя// 
М.: Диалектика, 2006 г. 944с. 
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